Messages: 314

Enregistré le: 15 Oct 2007

Message le Mar Juin 21, 2016 9:50

Bonjour,
je suis en train de mettre en place un site web avec une adresse en https (1and1 propose gratuitement le https depuis peu)
j'ai donc afin d’éviter le duplicate content mis dans mon htaccess ces lignes :

Code: Tout sélectionner
Options +FollowSymLinks
RewriteEngine on
RewriteCond %{HTTP_HOST} ^mondomaine.com$
RewriteRule ^(.*) https://www.mondomaine.com/$1 [QSA,L,R=301]

Redirect permanent / https://www.mondomaine.com/

ErrorDocument 404 https://www.mondomaine.com/


le soucis c'est que j'ai ce retour des navigateurs :
La page www.mondomaine.com ne fonctionne pas

www.mondomaine.com vous a redirigé à de trop nombreuses reprises.


Quel corrections dois-je apporter pour que mes redirection et réécritures fonctionne bien ?
Haut
3 Réponses
Messages: 253

Enregistré le: 22 Oct 2015

Message le Mar Juin 21, 2016 10:07

je comprends pas ce que vient faire la ligne d'erreur 404 retournant vers l'index

et faudrait que l'on ait l'url car les certificat ssl ne sont pas validés pas tous les navigateurs ce qui peut poser certains problèmes...
Haut
Messages: 314

Enregistré le: 15 Oct 2007

Message le Mar Juin 21, 2016 10:11

en fait :

Options +FollowSymLinks
RewriteEngine on
RewriteCond %{HTTP_HOST} ^mondomaine.com$
RewriteRule ^(.*) https://www.mondomaine.com/$1 [QSA,L,R=301]

>> si on oublie les www sa redirige vers les www

Redirect permanent / https://www.mondomaine.com/

>> la c'est pour que toutes les adresses soient bien en https

ErrorDocument 404 https://www.mondomaine.com/

>> ça c'est pour que si une url n'existe plus je redirige vers la page d'accueil.
Haut
Messages: 314

Enregistré le: 15 Oct 2007

Message le Mar Juin 21, 2016 10:16

j'ai trouvé cette solution qui semble fonctionner.

RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
Haut