Messages: 248

Enregistré le: 4 Fév 2010

Message le Lun Sep 16, 2013 14:09

Bonjour,

J'ai un blog de recettes de cuisine http://recette-de-cuisine-facile.net, où j'avais mis en place il y a quelques temps (au moins 1 an ou 2 je crois) des "rich snippets" pour que Google affiche dans ses résultats les infos additionnelles sur les recettes (photo, temps de préparation, etc.)

J'avais utilisé la technique des "microformats" (en gros ajouter certaines classes CSS aux éléments à identifier). Ca fonctionnait. Mais depuis un bon moment je pense (j'ai mis du temps à m'en rendre compte) : plus rien ! Quand j'utilisais en effet l'outil de test de Google, il ne trouvait plus les infos...

Je suis donc retourné lire les conseils de Google aux webmasters sur le sujet, et ils parlent d'une nouvelle façons compatible avec d'autres moteurs de recherche : "schema.org".

J'ai donc mis en place cette technique. L'outil de Google m'affiche maintenant bien les données, donc il les comprend (par exemple avec ma recette d'oeuf à la coque http://recette-de-cuisine-facile.net/recettes/oeuf-a-la-coque-temps-de-cuisson/ : voici le résultat.

Le problème, c'est que cela fait un bon mois que j'ai mis en place, et il n'y a toujours rien d'affiché dans les résultats Google...
Est-ce que quelqu'un a une idée de ce qui cloche ? Comment faire apparaître ces infos ?

Merci pour votre aide !
Haut
3 Réponses
Messages: 729

Enregistré le: 23 Mai 2005

Message le Lun Sep 16, 2013 15:44

Salut,

Il y a des erreurs sur ta page, c'est surement pour cela que Google ne prend pas en compte tes modifs.
tu as :

Erreur : Missing required field "entry-title".
Erreur : Missing required field "updated".
Erreur : Missing required hCard "author".


et

Erreur : We did not accept "3 minutes" as cooking time.
Erreur : Cooking time should be in ISO 8601 format - http://www.w3.org/TR/xmlschema-2/#duration


Corrige ces erreurs et ça devrait le faire.
Haut
Messages: 248

Enregistré le: 4 Fév 2010

Message le Lun Sep 16, 2013 16:01

... je suis bête ou bien ?

En effet j'avais vu les erreurs sur "hatom" (mais je sais pas d'où ça vient, à creuser, ça fait pas partie du snippet "recipe"), mais zappé celle sur le temps de cuisson. Pourtant c'est bien affiché "3 min" dans leur aperçu alors je m'étais dit que c'était OK.

En tout cas merci, je vais bosser sur çette piste c'est surement la bonne !

A+
Haut
Messages: 248

Enregistré le: 4 Fév 2010

Message le Jeu Sep 26, 2013 11:07

Bon, j'ai toujours le même problème : l'extrait enrichi ne s'affiche pas dans Google pour mes recettes...

J'avais d'abord corrigé les erreurs sur les temps pour l'item recette = toujours rien.

J'ai alors corrigé les erreurs sur "hatom-feed" en ajoutant dans ma page les infos sur l'auteur et la date qui étaient absentes (même si en soi je ne pense pas que ça change grand chose pour la recette) : toujours rien !

Je n'ai pourtant plus d'erreur dans l'outil de test des rich snippets.
Ma page "oeuf a la coque" (2ème résultat google) est bien ré-indexée par Google, puisque si on regarde la version en cache elle date d'hier, avec à la fin de la recette la phrase "La recette <recette> a été publiée le <date> par <auteur>" qui m'a permis de corriger les erreurs de hatom-feed...

Est-ce que quelqu'un a une idée de comment faire pour afficher cet extrait enrichi ?
Y-a-t'il un point de contact Google pour demander des précisions sur cela (je n'ai pas trouvé) ?

Merci pour vos réponses !
Haut