Messages: 3

Enregistré le: 27 Fév 2017

Message le Mer Mar 01, 2017 15:09

Bonjour à tous,

Je vous contacte car j'ai un souci avec le site internet de ma société, et j'arrive au bout de mes (petites) compétences web, sans solutions à mon problème. Et malgré de nombreuses recherches sur internet, je ne trouve aucune solution.

Suite au lancement de la nouvelle version du site de mon entreprise www.gestonline.com (site en Wordpress), nous sommes passés dans la foulée sur un certificat SSL, et donc sur du https, sur un serveur dédié (donc pas de problème de mutualisation). Le souci : le 1er octet est très long à s'afficher, plus de 4 secondes. On a passé en revue l'intégralité des éléments du site pour voir s'il ne restait pas du http, on a réduire le poids de la page (désormais 1,5Mo), désactivé tous les plugins (ce qui réduit le ttfb à 3 sec mais qui pourrit considérablement l'affichage du site, évidemment)... On a essayé de passer en php7 (actuellement on est en 5.6), ce qui a tout fait planter :-/ Et là, j'arrive au bout des possibilités, et sans avoir résolu le problème ^^

Vous auriez une idées ?

Merci à tous, bonne journée !

Aurélien
Haut
8 Réponses
Messages: 8612

Enregistré le: 14 Mai 2003

Message le Mer Mar 01, 2017 15:24

Il faut désactiver les plugins et voir ceux qui prennent le plus de temps.
Xdebug peut aider à trouver, mais ça demande des compétences.

Revolution slider et avada mettent un énorme pâté de CSS en inline et bcp trop de scripts et css.

Je vois que tu as mis du cache :
"Caching is a workaround, not a solution."

NB: on voit de plus en plus de gens qui peinent à optimiser leur WP, serait-ce le début de la fin de WP ? :roll:
Haut
Messages: 2078

Enregistré le: 9 Aoû 2005

Message le Mer Mar 01, 2017 15:30

Vous auriez une idées ? - j'arrive au bout de mes (petites) compétences


Faire appel a un vrai dev ?
Haut
Messages: 3

Enregistré le: 27 Fév 2017

Message le Mer Mar 01, 2017 15:46

Spout => en effet, c'est ce que j'avais testé, ça fait baisser légèrement le ttfb (si j'enlève tout, on est quand même à 2,5sec??!!) mais ça ne résoud pas le souci :-( et effectivement, Revolution slider et layer slider font bien ramer le truc, dans les prochaines semaines je les virerai, mais même en les désactivant le problème n'est pas résolu...

Furtif => Merci ^^ pour info, si je vous contacte, c'est parce que je suis au bout des compétences des dev autour de moi également :-P le site a été fait par un vrai dev, et la personne en charge de l'admin réseau et des serveurs chez nous s'acharne à trouver une solution mais ne trouve pas non plus. D'où ma demande de coup de main ;-)
Haut
Messages: 2078

Enregistré le: 9 Aoû 2005

Message le Mer Mar 01, 2017 15:58

D'où ma demande de coup de main ;-)


25 scripts chargés..., 11 fonts...., 24 stylesheets..., un conflit script n'est pas a exclure... ca en fait du monde a l'entrée

autre--
https://www.gestonline.com/wp-content/themes/Avada/Avada/assets/fonts/ ... f2?v=4.5.0
Loaded By: https://www.gestonline.com/:611
Host: http://www.gestonline.com
IP: 37.110.197.51
Error/Status Code: 404
Priority: VeryHigh
Client Port: 49416
Request Start: 6.615 s

https://www.gestonline.com/wp-content/plugins/revslider/public/assets/ ... f2?v=4.5.0
Loaded By: https://www.gestonline.com/wp-includes/js/jquery/jquery.js?ver=1.11.3:1
Host: http://www.gestonline.com
IP: 37.110.197.51
Error/Status Code: 404
Priority: VeryHigh
Client Port: 49420
Request Start: 7.985 s
Haut
Messages: 3

Enregistré le: 27 Fév 2017

Message le Mer Mar 01, 2017 16:03

Furtif a écrit:
D'où ma demande de coup de main ;-)


25 scripts chargés..., 11 fonts...., 24 stylesheets..., un conflit script n'est pas a exclure... ca en fait du monde a l'entrée

autre--
https://www.gestonline.com/wp-content/themes/Avada/Avada/assets/fonts/fontawesome/fontawesome-webfont.woff2?v=4.5.0
Loaded By: https://www.gestonline.com/:611
Host: http://www.gestonline.com
IP: 37.110.197.51
Error/Status Code: 404
Priority: VeryHigh
Client Port: 49416
Request Start: 6.615 s

https://www.gestonline.com/wp-content/plugins/revslider/public/assets/fonts/font-awesome/fonts/fontawesome-webfont.woff2?v=4.5.0
Loaded By: https://www.gestonline.com/wp-includes/js/jquery/jquery.js?ver=1.11.3:1
Host: http://www.gestonline.com
IP: 37.110.197.51
Error/Status Code: 404
Priority: VeryHigh
Client Port: 49420
Request Start: 7.985 s


Ok, merci ! Je vais regarder de ce côté là. Déjà corriger les 2 erreurs 404, mais qui arrivent tard quand même dans le chargement
Haut
Messages: 1702

Enregistré le: 11 Nov 2007

Message le Ven Mar 03, 2017 9:36

Et enlever les dsn-prefetch : avec l'avènement de HTTP2 (au lieu de 1.1), ça ralentit plus les connexions que ça ne les accélère. Mais c'est clair que l'énorme pâté de CSS avec plein de fontes -qui doivent être toutes être chargées- avant même le body, ça doit bien faire ramer les navigateurs et le premier octet.

Il faudrait aussi connaître la TimeLine de chargement (par exemple avec le site Dareboost; il y en d'autres) pour voir ce qui prend du temps et ce qui est mal parallélisé.

Le certificat SSL peut être lent aussi si c'est mal configuré, surtout si cette lenteur n'est observée que depuis le passage au https.

De plus certaines ressources ne sont pas accessibles : https://www.gestonline.com/?w3tc_minify=22a3f.js ce qui ne doit pas aider...

Le chargement du DOM prend 8 secondes!!! Incroyable! Et ça, ça vient des polices, du css... Mais dans tous les cas, le serveur est mal configuré puisque pour du https, il n'y a que 10% chargé en HTTP2... déjà, ça améliorerait le temps de réponse en optimisant de côté là.
Haut
Messages: 12355

Enregistré le: 23 Nov 2005

Message le Ven Mar 03, 2017 11:20

Pour Wordpress, tu peux aussi installer https://fr.wordpress.org/plugins/p3-profiler/, qui permet d'identifier les plugins qui pèsent le plus sur les perfs.
Haut
Messages: 12355

Enregistré le: 23 Nov 2005

Message le Dim Mar 05, 2017 9:44

En complément : https://fr.wordpress.org/plugins/query-monitor/
Haut