Messages: 22

Enregistré le: 17 Juil 2006

Message le Ven Avr 25, 2008 11:49

problème .htaccess

Bonjour à tous.
J'ai appliqué à la lettre toutes les consignes, modifié sessions, page_rail et page_header, créé le .htaccess comme dit pour ovh avec le /repertoire... Or, si l'url se rewrite bien, apache m'envoie une erreur... Le problème c'est qu'ensuite, malgré la suppression de l'.htaccess ou sa modif en rewriteEngine off, ce sont toujours les pages rewritées avec l'erreur qui s'affichent, et ça m'oblige à supprimer et recharger tout mon répertoire phpBB.
Je vous donne le chemin (je précise que ce forum fait partie d'osdate, et que les login dans phpBB se font à partir d'osdate). Donc chemin du forum : osdate/forum/phpBB
Et voici le .htaccess qui plante :
[code]RewriteEngine On

RewriteRule ^forums.* /phpBB/index.php

RewriteRule ^mforum([0-9]*).* /phpBB/viewforum.php?f=$1&mark=topics

RewriteRule ^viewforum([0-9]*)-([0-9]*)-([0-9]*).* /phpBB/viewforum.php?f=$1&topicdays=$2&start=$3

RewriteRule ^forum([0-9]*).* /phpBB/viewforum.php?f=$1

RewriteRule ^ptopic([0-9]*).* /phpBB/viewtopic.php?t=$1&view=previous

RewriteRule ^ntopic([0-9]*).* /phpBB/viewtopic.php?t=$1&view=next

RewriteRule ^stopic([0-9]*)-([0-9]*).* /phpBB/viewtopic.php?t=$1&watch=topic&start=$2

RewriteRule ^utopic([0-9]*)-([0-9]*).* /phpBB/viewtopic.php?t=$1&unwatch=topic&start=$2

RewriteRule ^ftopic([0-9]*)-([0-9]*)-([a-zA-Z]*)-([0-9]*).* /phpBB/viewtopic.php?t=$1&postdays=$2&postorder=$3&start=$4

RewriteRule ^ftopic([0-9]*)-([0-9]*).* /phpBB/viewtopic.php?t=$1&start=$2

RewriteRule ^ftopic([0-9]*).* /phpBB/viewtopic.php?t=$1

RewriteRule ^ftopic([0-9]*).html /phpBB/viewtopic.php?t=$1&start=$2&postdays=$3&postorder=$4&highlight=$5

RewriteRule ^setopic_([0-9]*)-([a-zA-Z0-9]*).* /phpBB/viewtopic.php?t=$1&highlight=$2

RewriteRule ^sutra([0-9]*).* /phpBB/viewtopic.php?p=$1

Si quelqu'un a une idée sur ce qui ne va pas, merci d'avance...
Cordialement à tous
ps : j'espère avoir mis ce topic au bon endroit... Si ce n'est pas le cas, je vous fais toutees mes excuses.
Haut
Messages: 22

Enregistré le: 17 Juil 2006

Message le Sam Avr 26, 2008 0:43

erreur 404 sur l'url rewritée

Bonjour.
Tout est appliqué, l'url affichée est bien sous forme phpBB/forum1,2,3,4,etc.php, mais j'ai une erreur 404...
Not Found
The requested URL /phpBB/viewforum.php was not found on this server.
Apache/1.3.41 Server at XXXX.fr Port 80
Pourtant la page viewforum.php est bien dans le bon répertoire... Quézaco ?

Je tourne en rond, si une bonne âme charitable pouvait m'éclairer, je brulerais un cierge pour lui. Merci de votre bienveillance.
Haut
Messages: 22

Enregistré le: 17 Juil 2006

Message le Sam Avr 26, 2008 1:30

tout est réglé...

désolé de vous avoir dérangé... Finalement c'était un problème de répertoire. Le répertoire phpBB était lui-même dans un répertoire forum. Le .htaccess se trouvait dans /phpBB, mais chez ovh, l'adressage dans le .htaccess était en réalité /forum/phpBB
Haut
Messages: 0

Enregistré le: 30 Nov 2010

Message le Mar Nov 30, 2010 4:56

Re:

solodown a écrit:puis mon .htaccess j'ai déja sa

Code: Tout sélectionner
DirectoryIndex portal.php index.php index.htm index.html


et pour info je suis chez OVH


j'ai pas compris
Haut
Messages: 31

Enregistré le: 1 Oct 2008

Message le Mer Déc 15, 2010 22:22

Pour moi aussi, c'est dur...je vais tout relire.
Haut
Messages: 18372

Enregistré le: 5 Juin 2006

Message le Mer Oct 15, 2014 13:42

Discussion remontée par un spam
Haut