Message d'erreur au chargement de l'include de robots stats

matthieu106
Nouveau WRInaute
Nouveau WRInaute
 
Messages: 2
Enregistré le: 2 Sep 2006

Message d'erreur au chargement de l'include de robots stats

Message le Jeu Oct 05, 2006 23:21

Je sais qu'il a déjà des sujets sur les messages d'erreur mais je n'en ai pas trouvé qui ressemble a mien. Donc voila avant Robotstat fonctionné très bien maintenant ça m'affiche cela :

Warning: stristr() [function.stristr]: Empty delimiter. in /mnt/135/sdc/5/5/woueblog/robotstats/robotstats.inc.php on line 30

Pour moi ça ne veut pas dire grand chose... au cas où mon site est hébergé chez free, ils ont du changer quelques choses dans la config PHP mais je ne voit pas quoi (en même temps je ne m'y connais pas beaucoup)...

Par contre le logo de robots stats et toujours la et robots stats enregistre encore les passages des robots...

Annonces Google

rog
WRInaute passionné
WRInaute passionné
 
Messages: 1665
Enregistré le: 21 Sep 2006

Message le Ven Oct 06, 2006 0:18

il est possible de verifier

tu ouvres ton script dans un editeur qui affiche les lignes
tu vas à la ligne 30
tu regardes la fonction stristr()
le premier argument est nul

rog

matthieu106
Nouveau WRInaute
Nouveau WRInaute
 
Messages: 2
Enregistré le: 2 Sep 2006

Message le Ven Oct 06, 2006 20:19

J'ai était voir dans la ligne 30 avec NotePad et, il n'y a pas de fonction stristr(), de plus c'est loin d'être l'endroit ou est positionné le script du robot la ligne 30...
J'ai donc enlever le script de robots stats pour voir et l'erreur n'apparaît plus.
Bon le problème c'est que je me retrouve sans les passages des robots ... :cry:


Lectures recommandées sur ce thème :