Messages: 79

Enregistré le: 3 Aoû 2005

Message le Jeu Mar 02, 2017 16:48

Bonjour,

lorsque je cherche "maquette avion Suisse" sur Google, je suis en première position (www.gdkits.com).
Malheureusement, je constate que google met un lien "traduire cette page" à côté du résultat de recherche.

Il y a certes de éléments en anglais, mais la grande majorité du texte est en français. J'ai rajouté récemment les tags suivants:
<meta http-equiv="Content-Language" content="fr">
<meta name="language" content="fr">
Ils sont dans la version en cache qui affiche le lien de page à traduire...

ça fait plusieurs mois que j'ai le code <html dir="LTR" lang="fr"> en début de page, hors il continue à la détecter en anglais.
Je n'ai pour l'instant pas la langue dans l'URL, je suis en train d'essayer de la rajouter, mais je crains que ce ne soit suffisant. Mes concurrents, qui affichent pratiquement le même contenu, n'ont pas ce problème. Est-ce que vous auriez une idée de l'origine du problème ? C'est du OSCommerce et il n'est pas envisageable de changer de plateforme actuellement donc ce n'est pas une option.

Merci pour votre aide.
Haut
2 Réponses
Messages: 12288

Enregistré le: 23 Nov 2005

Message le Jeu Mar 02, 2017 16:59

Google s'en cogne de la balise Content-Language. A mon sens, le gros souci du site c'est que toutes tes langues sont au même niveau sur le domaine (la racine).

A ta place, je migrerais en dossier les autres langues (tout en laissant le FR à la racine) et je mettrais en place des balises hreflang.
Haut
Messages: 79

Enregistré le: 3 Aoû 2005

Message le Jeu Mar 02, 2017 17:05

UsagiYojimbo a écrit:Google s'en cogne de la balise Content-Language. A mon sens, le gros souci du site c'est que toutes tes langues sont au même niveau sur le domaine (la racine).

A ta place, je migrerais en dossier les autres langues (tout en laissant le FR à la racine) et je mettrais en place des balises hreflang.


Merci pour ta réponse.

OK donc rajouter <link rel="alternate" href="www.gdkits.com" hreflang="fr"> dans le header ?

J''ai malheureusement plusieurs URL identiques pour le même article et c'est le cookie qui va définir la langue. Je suis en train d'essayer de rajouter un paramètre dans l'URL mais c'est pas facile car j'utilise un module pour le réécriture des URL.

Merci pour ton aide.
Haut