Messages: 3

Enregistré le: 8 Jan 2013

Message le Jeu Nov 03, 2016 11:44

C'est la première fois que je me trouve dans une telle situation - habituellement, sans pb, mon site se situe en première page, voire en première ligne sur le mot cle choisi et pour ce site, je suis en 7°/ 8° page et ca dégringole sans que je trouve l'origine du pb, sauf que çà doit venir d'un pb de 301 et/ou https / http
J'ai indiqué les 4 propriétés à la console Google, le sitemap est opérationnel et si je fais site:lamaisondelacolline.fr j'ai bien toutes mes pages. L'analyse des mots clés est correcte..
Je pédale dans la semoule...;
Entre autres, ce que je ne comprends pas, c'est que je mets une redirection vers https et le navigateur me renvoie sur http....
Si une âme charitable pouvait me donner une piste ...
Voici l'url : https://www.lamaisondelacolline.fr
le htaccess:
Code: Tout sélectionner
## Mod_rewrite in use.
RewriteEngine On
RedirectPermanent /www.lamaisondelacolline.fr/index.php https://www.lamaisondelacolline.fr
RedirectPermanent /lamaisondelacolline.fr/index.php https://www.lamaisondelacolline.fr
# redirection 301
RewriteEngine on
RewriteCond %{HTTP_HOST} ^lamaisondelacolline.fr$
RewriteRule ^(.*) https://www.lamaisondelacolline.fr/$1 [QSA,L,R=301]

Mille mercis...
Haut
4 Réponses
Messages: 90

Enregistré le: 4 Mai 2016

Message le Jeu Nov 03, 2016 21:43

Bonjour,

Il y a une documentation technique sur WRI qui explique comment faire

Code: Tout sélectionner
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
Haut
Messages: 3

Enregistré le: 8 Jan 2013

Message le Ven Nov 04, 2016 6:26

Hello,
Merci pour cette réponse, mais çà ne marche pas.
Je l'avais déjà essayé et le serveur me renvoie la réponse bien connue :

"www.lamaisondelacolline.fr vous a redirigé à de trop nombreuses reprises."

J'enrage, d'autant plus que j'ai d'autres sites en https et que çà fonctionne nickel !
Haut
Messages: 90

Enregistré le: 4 Mai 2016

Message le Ven Nov 04, 2016 9:58

Salut,

Ce code a été testé et approuvé des centaines de fois ;-)

Le problème vient certainement de redirections infinies :
http redirige vers https qui redirige vers http et ainsi de suite.

Il faut que tu trouves et que tu supprimes la redirection https vers http. Si tu utilises un CMS regarde dans l'administration du site.
Haut
Messages: 37930

Enregistré le: 7 Juil 2004

Message le Ven Nov 04, 2016 12:30

Bonjour,

Vous pouvez aussi demander des avis concernant votre site :
http://forum.webrankinfo.com/avis-sur-vos-sites.html
pour améliorer un peu celui-ci.

Cordialement.
Haut