Messages: 218

Enregistré le: 23 Fév 2004

Message le Lun Aoû 04, 2008 17:26

Lorsque je réactualise ma page sur I.Explorer (touche F5), les marqueurs (Google Maps API) positionnés sur ma carte disparaissent (la carte reste visible).

Voir http://www.locations-de-vacances.info/83/locations.htm par exemple.

De plus, pour retrouver ces marqueurs il faut fermer la fenêtre I.E. et en rouvrir une autre.

Pas de problèmes avec Firefox.

Merci de m'aider.
Haut
5 Réponses
Messages: 5

Enregistré le: 9 Aoû 2006

Message le Mer Aoû 06, 2008 10:19

On m'a déjà signalé ce problème avec ma carte qui est dispo ici http://www.tennis2table.com/localisatio ... e-maps.htm

J'ai conseillé aux utilisateurs d'utiliser Firefox...
Haut
Messages: 718

Enregistré le: 30 Mai 2007

Message le Mer Aoû 06, 2008 14:20

J'ai eu un soucis sur IE avec mon site aussi, et la solution que j'ai trouvé est de passer le script js qui genere la map dans le body, et non plus dans le head.
Haut
Messages: 218

Enregistré le: 23 Fév 2004

Message le Mer Aoû 06, 2008 17:12

Bonjour,

J'ai essayé avec script en début de body, ça ne marche pas, idem en supprimant le onload et le on unload.

@+
Haut
Messages: 218

Enregistré le: 23 Fév 2004

Message le Mer Aoû 06, 2008 17:46

EUREKA,
entre les diverses fonctions et la création de la carte dans le script, il y avait un problème d'ordre, c'est réglé, n'ai plus qu'à me corriger une cinquantaine de cartes défectueuses.
merci à ceux qui ont passé un moment à chercher.
Haut
Messages: 718

Enregistré le: 30 Mai 2007

Message le Mer Aoû 06, 2008 17:52

De rien, et bon courage pour tes modifs ;)
Haut