Messages: 6

Enregistré le: 22 Juil 2009

Message le Ven Déc 02, 2016 16:03

Bonjour la communauté WebRankInfo !

Mon site dj-macon.fr a été indexé par Google en HTTPS (suite à l’activation automatique du SSL par OVH).

Certaines pages apparaissent depuis en doublons dans les SERP (version HTTP et HTTPS) quant à ma page d’accueil seule la version HTTPS est disponible (la version HTTP n’étant plus indexée) à mon plus grand désarroi.

Vous vous douterez bien que je n’étais pas préparé à une telle migration !

J’ai pris connaissance de cette indexation le lundi 28 Novembre au soir. J’ai immédiatement effectué le nécessaire depuis mon administration OVH pour supprimer le SSL dans la nuit du lundi 28 Novembre au mardi 29 Novembre. Suite au contact téléphonique que j’ai eu avec OVH, un conseiller me confirme que le SSL n’est plus actif et qu’il suffit d’attendre un nouveau passage de GoogleBot pour qu’il prenne en compte cette modification et que Google actualise ses résultats.

J’ai mis à jour mon sitemap et l'ai envoyé depuis Search Console (tous les liens sont bien en -http://... sur celui-ci).

J’ai ajouté cette ligne de code en haut de mon fichier .htaccess à la racine de mon site suite aux recommandations d’Olivier dans son article

Code: Tout sélectionner
RewriteEngine on
RewriteCond %{SERVER_PORT} 443
RewriteRule .* http://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]


A aujourd’hui, Google propose toujours la version HTTPS de ma page d’accueil ce qui demeure être très embêtant.

Combien de temps pensez-vous que cela risque de durer avant que Google actualise ses résultats et propose la version HTTP en remplacement de HTTPS ?

Aurais-je oublié une étape importante pour favoriser cette modification ?

Avez-vous des conseils pour « accélérer » cette mise à jour des résultats ?

Merci pour votre réactivité et votre aide qui me seront très chères.

Florian
Haut
9 Réponses
Messages: 8555

Enregistré le: 14 Mai 2003

Message le Ven Déc 02, 2016 17:17

sonovation a écrit:Aurais-je oublié une étape importante pour favoriser cette modification ?

Oui: laisser le HTTPS et mettre une redirection du HTTP vers HTTPS.
Haut
Messages: 6

Enregistré le: 22 Juil 2009

Message le Ven Déc 02, 2016 17:39

Merci Spout pour votre réponse mais je souhaite conserver la version HTTP de mon site pour le moment.

Quelqu'un aurait-il quelques infos pour m'éclairer ?

Les actions que j'ai réalisé sont-elles correctes ?

Suffit-il que je sois patient pour voir HTTPS se retirer des résultats de Google et voir réapparaître mon accueil en HTTP ?
Haut
Messages: 12288

Enregistré le: 23 Nov 2005

Message le Ven Déc 02, 2016 19:31

Si le ssl a été désactivé, je vois mal comment la 301 va fonctionner...

La preuve : http://www.webrankinfo.com/outils/header.php?url=https%3A%2F%2Fwww.dj- ... internaute
Haut
Messages: 6

Enregistré le: 22 Juil 2009

Message le Ven Déc 02, 2016 19:46

Merci UsagiYojimbo pour votre message très instructif.

Si je comprends bien, l'ajout du code dans le .htaccess ne sert à rien dans mon cas ? (SSL désactivé, avec pour objectif de conserver le protocole HTTP)

Selon vous, me suffit-il de patienter pour que Google désindexe les pages HTTPS et ré-indexe mon accueil en HTTP ?
Haut
Messages: 12288

Enregistré le: 23 Nov 2005

Message le Ven Déc 02, 2016 20:04

J'aurai plutôt tendance à opter pour la solution de spout : faire réactiver le https et paramétrer celui-ci par défaut.
Haut
Messages: 6

Enregistré le: 22 Juil 2009

Message le Ven Déc 02, 2016 20:27

Merci pour vos precisions. Je vais m'intéresser au sujet. Comme indiqué dans mon premier post je n'étais pas forcément "prêt" pour cette migration. (Actualisation des backlinks pour éviter les 301, actualisation des liens internes pour éviter les 301, ...)

Mais ma question de départ n'etait pas forcément HTTP ou HTTPS.

J'aimerai dans l'immédiat récupérer la version HTTP de ma page d'accueil dans les SERPs. Le seul fait de désactiver le SSL est suffisant comme me l'indique mon hébergeur ?
À quel délai dois-je m'attendre pour que Google le prenne en compte ? (J'imagine que ça dépend de la fréquence de crawl ?)

Merci pour votre éclaircissement.
Haut
Messages: 12288

Enregistré le: 23 Nov 2005

Message le Ven Déc 02, 2016 22:05

Le plus simple est de réactiver le ssl pour que la redirection fonctionne. Sans cela, ça risque d'être long. Très long.
Haut
Messages: 6

Enregistré le: 22 Juil 2009

Message le Ven Déc 02, 2016 23:40

Je lis partout que le passage à HTTPS dans une seule optique SEO n'est pas conseillé vu les nombreux inconvénients liés à cette migration.

N'existe t-il pas une autre solution moins ennuyeuse ? J'imaginais que l'actualisation (retour de ma page d'accueil en HTTP dans les résultats de Google) serait plus rapide, ce qui me met dans l'embarras.

Au commencement, j'aurai préféré qu'OVH n'active pas automatiquement le SSL, et cela sans m'avertir. Je ne serai pas dans cette situation délicate.

Je n'aurai pas la disponibilité pour me concentrer sur cette éventuelle migration ce week-end. Cela me laisse le temps de la réflexion.

Je vous remercie vivement pour vos explications qui me semblent claires.

Aussi, j'aimerai recevoir d'autres avis sur la source de mon problème. D'autres personnes pour intervenir ?
Haut
Messages: 2765

Enregistré le: 14 Aoû 2002

Message le Sam Déc 03, 2016 10:03

Bonjour Monsieur

Le https c'est l'avenir, le long terme...

Je suis en https depuis deux ans environ.

Et mon site est gratuit.

Respectueusement.
Haut