Messages: 160

Enregistré le: 4 Avr 2004

Message le Mer Oct 15, 2014 14:34

Salut à tous

Un petit souci qui n'en est peut être pas un. J'ai découvert il y a peu les tools de bing pour les webmasters.
Depuis mon inscription, le système me harcèle avec des messages d'erreurs me disant qu'il y a un nombre affolant de 403 sur mon site.
Ceci est parfaitement normal pour moi : sur mon forum, les boutons "Répondre" apparaissent sur les pages de discussion et quand un utilisateur non identifié clique dessus, il a la page standard du site avec un texte l'invitant à s'incrire/s'identifier et une erreur 403 est envoyé. Je viens d'ailleurs en écrivant ce message et en vérifiant tout ça que la 401 serait surement plus appropriée (ce que je corrige de suite).
Pour espérer être tranquille, j'ai ajouté à ces fameuses pages il y a qqs semaines un header('X-Robots-Tag: noindex'); mais cela n'a rien changé.

D'après vos expériences, que faut il faire dans cette situation ? (Je précise que les tools de Google ne semblent pas s'émouvoir une seconde de tout ça ...)

Merci à ceux qui répondront !

B.
Haut
4 Réponses
Messages: 8559

Enregistré le: 14 Mai 2003

Message le Mer Oct 15, 2014 14:41

C'est plutôt une 401 que ça devrait renvoyer: http://fr.wikipedia.org/wiki/Liste_des_codes_HTTP#Erreur_du_client_.2F ... erveur_web
Haut
Messages: 160

Enregistré le: 4 Avr 2004

Message le Mer Oct 15, 2014 14:48

Merci pour ta réponse.
J'ai effectivement consulté cette page wikipedia.
Comme dit dans mon message initial, je viens de faire la correction.
Tout de même, si on suit la définition stricte donnée sur la 403, il n'y a aucune raison que Bing s'émeuve à répétition de ces 403 car le cas peut parfaitement se présenter sans que cela soit une anomalie.
On va bien voir si la flopée de 401 l’empêche aussi de dormir ... !

B.
Haut
Messages: 623

Enregistré le: 21 Juil 2014

Message le Mer Oct 15, 2014 14:51

ce qu'il est possible de faire, c'est de detecter les robots avec leur user agent, et de ne pas mettre le lien répondre pour les robots.
Haut
Messages: 160

Enregistré le: 4 Avr 2004

Message le Mer Oct 15, 2014 14:59

baud74 a écrit:ce qu'il est possible de faire, c'est de detecter les robots avec leur user agent, et de ne pas mettre le lien répondre pour les robots.


L'usine à gaz :-D juste pour ça !
Je crois qu'à un moment, il faut quand même raison garder. L'objet de mon message est en résumé de m'assurer que ma démarche est logique. En ça Spout corrige et confirme ce que j'avais anticipé. Après si tout le monde pense que la logique est la bonne, je ne me vois pas me lancer dans un palliatif ayant pour seul but de plaire à un système tiers. Je pense que depuis 15 ans, on en a tous soupé déjà avec Microsoft de ce côté-là ... on ne va pas remettre le couvert encore une fois surtout quand l'utilisateur final n'est pas touché !


B.
Haut