pb avec l'API Yahoo BOSS (caractères mal échappés)

Consultez la formation au REFERENCEMENT naturel Google de WebRankInfo / Ranking Metrics

karine_83
Nouveau WRInaute
Nouveau WRInaute
 
Messages: 2
Enregistré le: 12 Jan 2009

Message le Lun Jan 12, 2009 15:03

Salut...
j'utilise l'api yahoo boss et j'ai un petit pb ...en fait il me dit qu'y a une erreur "failed to open stream: HTTP request failed! HTTP/1.1 400" ...j'ai vu sur le site de yahoo boss...apparemment il s'agit de caractères mal échappés...

je vous mets mon code pour que vous me disiez si y a une erreur :
$tabcar = array("/","?","&",";",":","@",",","$","="," ","%","\"","+","#","*","<",">","{","}","|","[","]","^","/","`");

j'ai créé un deuxieme tableau pour les symboles...

qu'est-ce qui cloche dans ce que j'ai fait ??

Merci d'avance

Tilt
WRInaute impliqué
WRInaute impliqué
 
Messages: 861
Enregistré le: 26 Mar 2005

Message le Mar Jan 13, 2009 15:45

Bonjour, Bienvenue,

Il y a des fonctions en PHP qui normalement s'occupent de convertir les chaînes pour les requêtes : du coté de urlencode peut-être ?

Si je suis tombé à coté du problème, tu peux être plus précise ?

karine_83
Nouveau WRInaute
Nouveau WRInaute
 
Messages: 2
Enregistré le: 12 Jan 2009

Message le Mar Jan 13, 2009 17:42

Merci...
en fait j'ai réglé le problème toute seule ! C'était tout bête..il fallait que je me serve du second tableau que j'avais fait avec les codes des caractères spéciaux et que je les remplace dans ma variable finale !


Formation recommandée sur ce thème :

Formation REFERENCEMENT naturel Google : apprenez une méthode efficace pour optimiser à fond le référencement naturel dans Google de façon durable... Formation animée par Olivier Duffez et Fabien Facériès, experts en référencement naturel.

Tous les détails sur le site Ranking Metrics : programme, prix, dates et lieux, inscription en ligne.

Lectures recommandées sur ce thème :