Messages: 53

Enregistré le: 5 Mar 2009

Message le Mar Mar 14, 2017 15:47

Bonjour
mon site n'est pas en https et aujourd’hui dans Google, l'url de mon site apparaît:
https://www.mondomaine.com
alors qu'avant il apparaissait comme ci:
http://www.mondomaine.com

Comment se fait il que google le déclare en HTTPS alors que je n'ai rien fait et comment y remédier ?
Merci pour vos réponses
Haut
8 Réponses
Messages: 12247

Enregistré le: 23 Nov 2005

Message le Mar Mar 14, 2017 16:39

Est-ce que le site fonctionne en https ? Certains hébergeurs activent les certificats SSL de manière transparente depuis quelques temps.
Haut
Messages: 53

Enregistré le: 5 Mar 2009

Message le Mar Mar 14, 2017 18:09

Le problème est là... le site ne fonctionne pas en Https
Haut
Messages: 53

Enregistré le: 5 Mar 2009

Message le Ven Mar 17, 2017 12:26

:evil: Ne pouvant le faire au niveau HTACCESS ni au niveau du serveur
Comment peut on demander à GOOGLE de supprimer l'HTTPS qu'il rajoute dans à l'url du site dans les résultats de recherche ?
Existe t'il moyen de leur demander ? un formulaire, un contact ?
Haut
Messages: 23079

Enregistré le: 19 Avr 2002

Message le Ven Mar 17, 2017 12:37

Google a dû estimer que le site répond en HTTPS, et dans ce cas Google affiche le HTTPS dans les résultats même si le site à la base est en HTTP :-(
Haut
Messages: 53

Enregistré le: 5 Mar 2009

Message le Ven Mar 17, 2017 13:26

WebRankInfo a écrit:Google a dû estimer que le site répond en HTTPS, et dans ce cas Google affiche le HTTPS dans les résultats même si le site à la base est en HTTP :-(


Oui mais le problème est que le site ne peut pas fonctionner en HTTPS car il n'y a pas de certificat pour ce site.
Il est effectivement sur un serveur mutualisé ou 1 site a son certificat.
Haut
Messages: 23079

Enregistré le: 19 Avr 2002

Message le Ven Mar 17, 2017 13:36

dans ce cas il faut mettre en place les redirections de https vers http
Haut
Messages: 53

Enregistré le: 5 Mar 2009

Message le Ven Mar 17, 2017 13:57

WebRankInfo a écrit:dans ce cas il faut mettre en place les redirections de https vers http


Oui c'est ce que j'ai essayé de faire mais mon site étant sur un mutualisé google je pense attribut le HTTPS à l'ensemble des sites car sont sur la même IP.
J'ai beau essayer de faire les modifications dans mon htaccess, rien ne passe.
J'ai essaé les solution standard en htacces et dans le web.config du site

Code: Tout sélectionner
<configuration>
<system.webServer>
<rewrite>
<rule name="Redirect to HTTP" stopProcessing="true">
  <match url="(.*)" />
  <conditions>
    <add input="{R:1}" pattern="^(.*)$" negate="true" />
    <add input="{HTTPS}" pattern="^ON$" />
  </conditions>
  <action type="Redirect" url="http://{HTTP_HOST}/{R:0}" redirectType="Permanent" />
</rule>
</rewrite>
</system.webServer>
</configuration>
Haut
Messages: 12247

Enregistré le: 23 Nov 2005

Message le Ven Mar 17, 2017 19:03

Dans le .htaccess :

Code: Tout sélectionner
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
Haut